Can't run locally - How to populate

I鈥檓 trying to set up Lago locally using this guide Development Environment 路 getlago/lago Wiki 路 GitHub

and I got stuck on this part

Populate the ./api/config/master.key

Not really familiar with mkcert or traefik.

Looking forward hearing from you guys!

Hi bri,

Thank you for trying lago and for your question.

The documentation of the wiki is more intended for contributors. If you just want to run the project locally, I encourage you to look at the self hosted documentation.

I will clarify it on the Github wiki.

Let us know if you need more help with this setup.

Cheers,
Vincent

Hi vincent!

Thank you for the quick reply and I was able to follow the guide.

I tried setting this up in DigitalOcean and I鈥檓 having a CORS issue. You can check it out on this link http://157.230.35.247/

I updated the LAGO_API_URL to this value http://157.230.35.247:3000 and allowed access in the port 3000 by running this command sudo ufw allow 3000. Just want to try this out and show it to my product manager if this is something we could use with our existing workflow.

Hi bri!

Good to know you manage to run it on DigitalOcean.

It appears the URL/IP address of the front end application is not whitelisted on the back-end side CORS configuration.
Since you updated LAGO_API_URL, could you also update LAGO_FRONT_URL to http://157.230.35.247/ and let me know if it fixes the issue?

Hi vincent!

This is the fix. Thanks for all the help :slight_smile:

1 Like